Twenty Elevenのバージョンアップ時の修正

WordPressのTwenty Elevenテーマのバージョン上げたら不具合が出たので覚え書き
そういえばTwenty Elevenの子テーマにしてから初めてのバージョンアップだった

テーマのバージョン上げると毎回修正が必要

functions.php
子テーマフォルダにコピーしただけで500エラーが出る、親ファイルを直接弄るしかない

[html]
<h3 class="assistive-text"><?php _e( ‘Post navigation’, ‘twentyeleven’ ); ?></h3>
<div class="nav-previous"><?php next_posts_link( __( ‘<span class="meta-nav">&larr;</span> Older posts’, ‘twentyeleven’ ) ); ?></div>
<div class="nav-next"><?php previous_posts_link( __( ‘Newer posts <span class="meta-nav">&rarr;</span>’, ‘twentyeleven’ ) ); ?></div>
[/html]

functions.php内にある上記の3行をWP-PageNavi表示のためのコードに書き換える

[html]
<?php wp_pagenavi(); ?>
[/html]

これでページナビゲーションがWP-PageNaviの表示になる

スポンサーリンク